h1

RedHat Enterprise Linux y Suse Novell actualizan Kernel

julio 5, 2008


Red Hat ha publicado una actualización del kernel que corrige varios fallos de seguridad que podrían permitir a un atacante local causar una denegación de servicio o acceder a información sensible. Novell ha publicado una actualización de kernel de SuSE Linux que corrige diversas vulnerabilidades que se describen a continuación.

Sobre la actualización del Kernel de Red Hat:

* Se ha encontrado un fallo en las rutinas de copia de memoria en el kernel de Linux al ejecutarse en ciertos sistemas AMD64. Si falla un intento de copia de memoria del kernel, las rutinas no ponen a cero las porciones de memoria que fueron copiadas en destino, lo que podría ser aprovechado por un atacante para ganar acceso a información sensible.

* Existe un fallo en la emulación de los kernel de 32 y 64 bits que podría ser aprovechado por un atacante para causar una fuga de datos por medio de un binario especialmente manipulado.

* Existe una falta de comprobación de límites en el subsistema DCCP (Datagram Congestion Control Protocol) del kernel de Linux. Esto podría ser aprovechado por un atacante local sin privilegios para elevar sus permisos en el sistema mediante la ejecución de código arbitrario al
aprovechar un desbordamiento de búfer.

Se recomienda actualizar a través de las herramientas automáticas up2date.

Sobre la actualización del Kernel de Novell Suse:

Se ha corregido un fallo no especificado que permitía a un atacante local efectuar una denegación de servicio a través de vectores no especificados.

* Condición de carrera en dnotify que podría permitir a un atacante local causar una denegación de servicio.

* Un atacante remoto podría causar una denegación de servicio en la pila IPSec/IPv6 por medio de paquetes ESP especialmente manipulados.

* Se ha corregido un fallo que borraba el flag de dirección antes de llamar a manejadores de señal, que podría permitir a un atacante remoto ejecutar código arbitrario en algunos programas no especificados bajo ciertas condiciones.

Se recomienda actualizar a través de las herramientas automáticas YoU (Yast Online Update).

Fuente:
https://rhn.redhat.com/errata/RHSA-2008-0519.html
http://support.novell.com/docs/Readmes/InfoDocument/patchbuilder/readme_5028579.html

Anuncios

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: